Pencil Code is now available in Codio installing from Tools->Install Software

PencilCode

With Codio guides you can provide instructions for an assignment side-by-side with the Pencil Code environment.

Start by creating either a new project or assignment in your course, and going to Tools -> Install Software to install the Pencil Code server

To create an empty Pencil Code project in Codio, select File > New from the Codio menu and create a file with an .pencilcode suffix.

You can set up your Guide to automatically open files you want your students to use. If you don't want the guide to take up screen space, you can set it up to collapse on open or students can simply click on the files in the file tree for them to open in Jeroo

For more information on Pencil Code, click here